Andrey (azangru) wrote,
Andrey
azangru

Емакс и жопа

2012 год:

> Since upgrading to Emacs 24, I have been having problems copy/pasting between Emacs and other X applications. I am using Archlinux with KDE and my emacs is:

> GNU Emacs 24.2.1 (x86_64-unknown-linux-gnu, GTK+ Version 3.4.4)
> of 2012-08-28 on shaun

> Symptoms:
>
> When I first start emacs I can copy/paste between something like Chrome and Emacs without a problem. However, after a while items I select from Klipper are not pasted into Emacs, but the last item from the Kill ring gets pasted instead. If I restart Emacs it works as I would expect for a certain number of copy pastes, but then the problem re-occurs.
>
> Relevant sections from my .emacs:
>
> (setq x-select-enable-clipboard t) ;use system clipboard
> (setq mouse-drag-copy-region nil) ; stops selection with a mouse being immediately injected to the kill ring
> (setq x-select-enable-primary nil) ; stops killing/yanking interacting with primary X11 selection
> (setq x-select-enable-clipboard t) ; makes killing/yanking interact with clipboard X11 selection
>
> I have read the Emacs wiki page about clipboard interaction, but can't
> see anything there that might help. My current setup works fine with
>
> Emacs 23.
> Ian.


2014 год, январь:

Well, (in a way) I'm glad I'm not the only one with this problem. I have it
with GNU Emacs 24.3.1 on Fedora 19 and Gnome and enquired about it on this
group on 2013-11-21 ("Intermittent problems with cut/copy and paste (using CUA
keys) between Emacs and other programs") where I asked how to go about tracking
down the bug, but got no response to that.

After Emacs has been running for a few days the problem starts to occur and I
have both the OP's problem of Emacs failing to paste from the system clipboard
and the reverse problem of Emacs failing to place cut/copied items into the
system clipboard.

I've found that I don't have to restart Emacs to clear the problem; I can clear
it (for a while) with a few copy/paste operations within Emacs. Of course that
barely mitigates the problem.

As I use Emacs to compose emails / news posts that and then have to be pasted
into web-based news/mail interfaces, this bug is a frequent annoyance.

I'd very much like to hear anyone's suggestions for tracking down the cause of
the issue.

N. Jackson.



2014 год, конец июля:
У меня, блин, то же самое :-(
Subscribe

Recent Posts from This Journal

  • (no subject)

    Tweeted and retweeted by developers. Dunno. Been working for me. Can't speak to excellence, but certainly lots of stimulating humiliation:

  • (C)opied from Twitter

    Don't know if this is real or not, but if it is, it's really strange that Canadian bureaucrats should be specifically instructed not to use the…

  • (no subject)

    This was a good talk. Interesting to see that SvelteKit is taking the same direction as Remix.run, by using html forms to submit data without the…

  • Post a new comment

    Error

    default userpic
    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 5 comments